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Introduction 
Congratulations on purchasing Transcend’s PF710. Now it’s easy to display your photo collection at home 
or at the office. The PF710 lets you conveniently access and playback photos and music from a variety of 
sources: USB Flash drives, all sorts of memory cards, or the PF710’s own on-board memory. PF710 can 
be operated easily with both its navigation buttons and the included remote control. Its easy image-rotating 
feature allows you to display your PF710 in either portrait or landscape position. The on-board storage 
space you save your favorite pictures and music inside PF710 for instant playback without even having to 
use a memory card. PF710 can also be connected to a PC via the USB port for direct access to its internal 
memory or any memory cards that are plugged into it. This User’s Manual will help you get the most from 
your new device. Please read it in carefully before using the PF710. 

Package Contents 
Upon purchasing your Transcend PF710, please make sure each of the following is included:  

 PF710 *1 

 Remote control (battery included) *1 

 Tabletop stand *1 

 Power adapter *1 

 USB cable *1 

 User’s Manual CD *1 

 Quick Start Guide *1 

 Warranty Card *1 

 

Features 
 Bright 7” high-resolution widescreen color TFT LCD panel 

 Built-in stereo speakers and headphone jack 

 Supports USB flash drives and SD/SDHC/MMC/MS/CF memory cards 

 Fully compliant with Hi-Speed USB 2.0 and backwards compatible with USB 1.1 

 Direct USB connection to your PC for easy file transfer 

 Built-in memory – works even without a memory card 

 Auto power on/off 

 Slideshow, thumbnail, still picture, and zoom-in viewing options 

 View photos with background music 

 Attractive Themes to accent your pictures with 

 Important date/event reminder 

 Clock, alarm and calendar functions 

 

 

 

 

In
tr

od
uc

tio
n 

 
In

tr
od

uc
tio

n 
 



 4

System Requirements 
System requirements for connecting PF710 to a computer: 

1. 100~240V voltage power outlet for the DC adaptor. 

2. Desktop or notebook computer with a working USB port. 

3. One of the following Operating Systems (OS): 

 Windows® 2000 

 Windows® XP 

 Windows® Vista 

 Mac™ OS 10.0, or later  

 Linux™ Kernel 2.4, or later  
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Safety Precautions 
These usage and safety guidelines are IMPORTANT! Please follow them carefully to ensure your own 
personal safety and help protect your PF710 from potential damage. 

General Use 
 Avoid using or placing this product in an extreme temperature environment. 

 Never allow this product to become damp or wet from water or any other liquids. 

 Do not use this product in environments with strong magnetic fields or excessive vibration. 

 Do not use a damp cloth to wipe or clean the exterior case or the LCD panel. 

 Only use the Transcend provided DC adapter for use with the PF710. Use of other DC adapters may 
cause a fire or explosion. 

 To protect your health and your hearing, keep the music volume of PF710 below 80 decibels and do 
not listen for an extended period of time. 

Backing Up Data 
 Transcend does NOT take any responsibility for data loss or damage during operation. If you 

plan to plug a memory card or USB pen drive into PF710, we strongly advise that you first backup the 
data in those storage devices to a computer or other storage medium before using them in PF710. 

 To ensure Hi-Speed USB 2.0 data transfer rates when connecting your PF710 to a computer, please 
check that the computer has the relevant USB drivers. If you are not sure how to check this, please 
consult the computer or motherboard User’s Manual for USB driver information. 
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First Time Use 

 

 

 
Figure 1: PF710 

Turn on PF710 
 

 

 

 

 

 

 

 

 

 

 

Figure 2: Attaching the tabletop stand to PF710(Landscape) 
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Figure 3: Attaching the tabletop stand to PF710(Portrait) 

 

1. Attach the Tabletop Stand to the back of the PF710 using the stand holes (Landscape) shown above. 
Landscape configuration is recommended for initial use. 

2. Connect the power adapter cable to the DC input jack on your PF710.  

3. Plug the power adapter into a wall outlet. 

 
Figure 4: Plug in the power adapter 

4. Press and hold the EXIT button for 3 seconds to power on/off your PF710, or press  on the 

remote control (with the PF710 facing you, EXIT is the navigation button on the far left). 

 

 

 

 

 

 

Figure 5: Removing the tabletop stand from PF710(Landscape) 
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Figure 6: Removing the tabletop stand from PF710(Portrait) 

Using a memory card or USB flash drive 

1. Insert a memory card into its appropriate card slot on the right-hand side of PF710 or plug a USB flash 
drive to the USB A-Type connector on the left-hand side. 

2. Once a memory card or USB flash drive is plugged in, PF710 will automatically begin slideshow 
playback of all photos available on your memory card or flash drive. 

3.  PF710 will revert to the Home menu if you unplug a memory card or USB flash drive while in use. 

 
Figure 7: USB flash drive slot and memory card slots 

Volume control and headphones 
The volume control wheel is located on the upper left side of PF710. Move it up to increase volume, and 
scroll down to decrease volume. Press inward on (click) the volume control wheel to mute. You can plug 
headphones into your PF710’s headphone jack to enjoy your music more personally. The built-in 
speakers will be disabled while headphones are plugged in, 

Navigation Buttons 
There are seven convenient navigation buttons located on the backside of the PF710, which are 
represented in this manual with capital letters (ex: EXIT = “exit” button on back of unit). From left to right 
(with the screen facing you) are: EXIT, OPTION, OK, UP, DOWN, LEFT, RIGHT. The menu options 
displayed in the OSD are mapped to the navigation buttons located behind each icon. 
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Remote Control 
Your PF710 comes with a compact, easy to use remote control. You can operate your PF710 with either 
the navigation buttons on the back of the PF710 or by using the remote control. Note that when using the 
remote control you should always aim it directly at the front of your PF710 and make sure there are no 
obstacles in the way. All icons like      shown in this User’s Manual and the Quick Start Guide represent 
functions that you can access directly from the remote control for easy, straightforward operation of your 
PF710. 

 : These menus can be directly accessed by pressing one of these shortcut buttons no 
matter what menu/mode the PF710 is currently in. 

  : Switch between Thumbnail and Slideshow modes. 

 : Select the item you want to view or function you want to perform. 

 : Show additional functions available for the current mode. 

 : Jump back to the Home menu no matter what menu/mode the PF710 is currently in. 

 : Go back to the last page or menu. 

 : Play/pause, or stop music.                           

  : Rotate or zoom-in on photos displayed in Photo View mode. 

 : Adjust music volume (up / down / mute). 

 : Cycle between music play modes. 

 

 

 

 

 

 

 

 

Figure 8: Remote control 
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Connecting to a Computer 
If you want to transfer pictures and music between the PF710 and your computer, connect the PF710 to a 
USB port on your computer using the provided Mini-B to A-Type USB cable. 

1. Turn on PF710.  

2. Plug the small end of the USB cable into the Mini-B USB port located on the left side of the PF710. 

 
Figure 9: Mini USB to USB A-Type Cable 

3. Plug the large end of the cable into an available USB port on your desktop or notebook computer. 

 
WARNING! You need to plug in the power adapter to provide the power necessary to run 
the PF710 when connecting to a computer. 

 
Figure 10: Connecting PF710 to a computer 

System connection for Windows® 2000, XP and Vista  

1. No drivers are required for connecting PF710 to your desktop or notebook computer. Windows® 

Operating Systems (excl. Windows98) have built-in drivers to support your PF710. Upon successful 
connection to your computer, a new Removable Disk drive with a newly assigned drive letter 
representing the PF710 will automatically appear in the My Computer window and a Removable 
Hardware    icon will appear in the Windows System Tray.  

 

 

 

 

 
Figure 11: The Find New Hardware Wizard auto-installs PF710 

2. Your PF710 is now ready to upload/download data just like an external hard drive. A number of 
Removable Disk* drives with newly assigned drive letters representing the PF710’s card slots (and its 
onboard memory) will appear in the My Computer window. You can transfer your pictures and music 
to the PF710 by simply by dragging-and-dropping files or folders onto these Removable Disk drive 
letters. 
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Figure 12: The “My Computer” window with PF710 drives shown. 

*Note: E:,F:,G:, and H: are example drive letters - the letters in your “My Computer” window may differ  

3. Proper removal of your PF710 (from Windows): 

 1. Click once on the Removable Hardware icon     in the system tray.  

 2. The Safely Remove Hardware pop-up window will appear. Select it to continue.  

 

 
Figure 13: Safely Remove Hardware  

 3. A window will appear stating, “The ‘USB Mass Storage Device’ device can now be safely 
removed from the system.” Unplug your PF710 from the USB port after this message appears.  

 
Figure 14: Safe to Remove Hardware  

System connection for Mac™ OS 10.0 or later 
1. No drivers are required. Plug your PF710 into an available USB port and your computer will 

automatically detect it. 

 
Figure 15: Connecting to a Mac OS computer  
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2. Proper removal of your PF710 (from Mac OS): 

First drag-and-drop the Disk icon corresponding to your PF710 into the trashcan then unplug your PF710 
from the USB port. 

System connection for Linux™ Kernel 2.4 or later 
1. No drivers are required. Plug your PF710 into a USB port and mount it. 

  a. First create a directory for the PF710. 

Example: mkdir /mnt / PF710 
b. Then, mount the PF710. 

Example: mount –a –t msdos /dev/sda1 /mnt / PF710 

2. Proper removal of your PF710 (from Linux): 

Execute umount /mnt/ PF710 to un-mount the device. Then unplug your PF710 from the USB port.  

 
1. WARNING! To prevent data loss, always follow the above procedure when removing the 

PF710 from Windows™2000, XP, and Vista. 

2. When PF710 is connected to a computer, it is locked into transferring files. You will not 
be able to operate your PF710 at this time. Please disconnect your PF710 from 
the computer to resume normal viewing or listening. 

3. The USB A-Type host controller for USB flash drives will not function while the Mini-USB 
B-Type is connected to your computer.   

4. NEVER format your PF710 from your computer’s OS. 
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The Home Menu 
The Home menu acts as a convenient gateway to access all of PF710’s functions. Selecting one of the 
four icons listed in Home menu (shown below) will activate the menu option listed underneath it. 

 

 

 

 

 

 

 

 

 

Figure 16: Home menu 

Photo 
This option lets you display photos in Thumbnail, Photo view or slideshow mode with special effects. 

Use the OSD (see note below) to select the “Photo” icon or press  to enter the Thumbnail mode 
directly. 

Music 
By selecting the Music option, you can playback music on your PF710, and even choose your favorite 

song to wake you up in the morning as your alarm sound. Use the OSD to select the “Music” icon or press 

 to open the Music Explorer. 

Clock and Calendar 
The “Clock and Calendar” option turns your PF710 into an attractive desk clock/calendar with pictures. 

In this mode you can mark important dates and holidays, and even choose a festive theme to go with them 

(i.e. hearts for Valentine’s day). Use the OSD to select “Calendar” or press  to enter Clock and 
calendar mode. 

Settings 
This option allows you to adjust the PF710’s many settings, such as switching languages or setting 

the clock. Use the OSD to select the “Settings” icon or press  to enter this menu option. 

 
H
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Note: The On-Screen Display navigation menu will appear in the top area of the screen whenever any 
button is pressed. The menu options displayed in the OSD are mapped to the navigation buttons located 
behind each icon. The OSD menu will disappear after 10 seconds without button input.  
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Photo 
Photo has three modes: (Thumbnail mode, Photo View mode and Slideshow mode). You can use the 
remote control to access these modes directly or navigate to them using the OSD. 

Thumbnail Mode 

Select Photo from the Home menu or press  to enter this mode. The Thumbnail Mode allows 
you to browse thumbnails of all photos in the current source (SD card, USB flash drive, etc.). Eight 
thumbnails per page will be displayed. Use the UP, DOWN, LEFT and RIGHT buttons to navigate to the 

thumbnail you want to view, then press OK or  to view the selected photo in Photo View mode. 

 
Figure 17: Thumbnail mode options menu 

Switching to Photo View mode: 
1. Navigate to the photo you want to view by using the UP, DOWN, LEFT and RIGHT buttons. 

2. Click OK or  to switch to Photo View mode. Note: If current item highlighted is a 

Motion-JPEG file it will start to play when this button is pressed. PF710 will go back to the 

Thumbnail mode after finishing playback of a Motion-JPEG file. 

 

Options : 
 This menu shows list of options available in the Thumbnail mode: Add/Remove from My Favorites 
(PF710’s internal storage), Slideshow, Photo View and Select source. 

1. Click OPTION or , and use the LEFT and RIGHT buttons to select the desired function. 

2. Click OK or  to access the highlighted function or open its sub-menu. 

a. Add to My Favorites / Remove from My Favorites: Copies the currently selected photo in 
the Thumbnail viewer to the PF710’s internal memory when the source is a memory card or 
USB flash drive. To remove a photo from the internal memory, select “My Favorites” as the 
viewing source, navigate to the desired thumbnail to remove, and then choose “Remove from 
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My Favorites.” 

b. Slideshow: Switch to Slideshow mode. 

c. Photo View: Switch to Photo View mode. 

d.  Select Source: Select the source to browse thumbnails from. The available sources are: My   
Favorites (internal memory), SD/MS/MMC, CF and USB flash drive. Use the LEFT and 

RIGHT buttons to highlight the desired storage media and click OK or  to select it. 

Exit : 
 Click EXIT or        to go back to the Home menu. 

 

Photo View Mode 
 You can view, zoom-in, or rotate a single photo in Photo View mode. Use the LEFT and RIGHT 
buttons to view the next or previous photo available. 

 

 

 

 

 

 

 

 

 
Figure 18: Photo View options menu 

Switching to Slideshow mode: 

Click OK or  while viewing a photo to switch to Slideshow mode. Note: Motion-JPEG files will be 

skipped in Slideshow mode. 

 

Options: 
 This menu shows a list of options available in the Photo View mode: Slideshow, Thumbnail, Zoom, 
Rotate, Themes, Background Music, Set as Clock and Calendar Picture, Save to file and Select source. 

1. Click OPTION or and use the LEFT and RIGHT buttons to select the desired function. 

2. Click OK  to access the highlighted function or open its sub-menu. 

a. Slideshow: Select this menu option or simply click  on the remote to enter Slideshow 
mode. 
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b. Thumbnail: Select this item or click  on the remote to enter Thumbnail mode. 

c. Zoom: Select this item to choose between x1, x2 and x4 zoom modes in the Zoom submenu. 

You can also press on the remote to automatically zoom-in on the current photo. You 

can go back to Photo View mode by pressing EXIT or . 

d. Rotate: Select this item and choose between clockwise 90o, 180o and 270o in the Rotate 

submenu.  Pressing  will rotate the current photo clockwise 90o each time you press it. 

(Rotate function only enabled at x1 zoom) 

e. Themes: This option brings up a submenu that lets you select theme frames to wrap around 

your photos while viewing in Slideshow or Photo View. Use the LEFT or RIGHT buttons to 

highlight None, X’mas, Halloween, Valentine’s Day or New Year’s Day, then click OK or 

 to confirm. 

f. Set as Clock and Calendar Picture: Sets current photo as the wallpaper in Clock and 
Calendar mode (and copies it to internal memory).  

g. Save to file: Copy current photo (with theme) to “My Favorites.” The photo and its theme will 
be saved as a new file in the internal memory for future access. 

Exit : 

 Click EXIT or        to go back to the Home menu. 

Slideshow Mode 
 This mode starts slideshow playback of all photos in the selected source. Slideshow mode will play 
based on the settings in the Options menu. Click the LEFT or RIGHT buttons to switch to the previous or 
next photo available. 

 

 

 

 

 

 

 

 

 
Figure 19: Slideshow options menu  
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Switching to Thumbnail mode: 

Click OK or  while viewing a slideshow to switch to Thumbnail mode. 

 

Options: 
 This menu shows a list of options available in the Slideshow Mode: Thumbnail, Photo View, 
Background Music, Slideshow order, Slideshow Interval, Slideshow transition effects, Themes and Select 
Source. 

1. Click OPTION or , and use the LEFT or RIGHT buttons to highlight the desired function. 

2. Click OK or  to access the highlighted function or open its sub-menu. 

a. Thumbnail: Select this item or click  on the remote to jump to Thumbnail mode. 

b. Photo View: Select this item to switch to Photo View mode for zoom-in and other functions. 

c. Background Music: Select this item to turn background music on/off, or simply click  

on the remote. Slideshow mode will remember your background music setting for next time: 

Selecting “Stop” or clicking  will stop playing background music, and it will not play the 

next time Slideshow is started. Selecting “Play/Pause” or clicking  will turn the function 

back on and music will play the next time Slideshow is started. 

d. Slideshow order: Select this to change the slideshow playback mode. Use the LEFT or 

RIGHT buttons to select Normal (continuous sequential playback) or Random (continuous 

random playback) in the submenu, and click OK or  to confirm.  

e. Slideshow Interval: Adjust the amount of time each picture stays on the screen. In the 

Slideshow interval submenu, use LEFT or RIGHT to highlight either: 5 secs, 10 secs, 30 secs, 

1 min, 10 mins or 30 mins. Click OK or  to confirm.  

f. Slideshow transition effects: Change the way the screen transitions between each photo. 

In the Transition effects submenu, Use the LEFT or RIGHT buttons to select the desired effect 

and press OK or  to confirm. 

 
Ph

ot
o 

 
 

Ph
ot

o 
 

 
Ph

ot
o 

 



 18

Exit : 

 Click EXIT or        to go back to the Home menu. 
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Music 

Music Explorer 

Choose “Music” from the Home menu or press  to open the Music Explorer. The Music 
Explorer lets you browse for individual songs in specific folders. The directory path is shown at the top 
of the screen. In the Music Explorer you will see all file folders on the current storage device. Use the 
UP and DOWN buttons to move to the desired folder. You can enter a folder by pressing RIGHT or 
OK, and exit a folder by pressing LEFT or selecting “Upper Directory.” Once you have located the 
music file you want to play, press the PLAY or OK button to start playing the song in Music Player. 

 
 
 

 

 

 

 

 

 
 

Figure 20: Music Explorer options menu 

Exit: 

Click the EXIT button  to return to the Home menu. 

   Option: 

In the Music Explorer mode, use the OSD to navigate to this icon or press OPTION or to reveal 

four submenu options: 

1. Add to My Favorites / Remove from My Favorites: Copy the current highlighted music file from 
your storage media (CF, USB flash drive, etc.) to PF710’s internal memory. To remove songs from 
the internal memory, change the media source to “My Favorites” and select Remove from My 
Favorites from the Options menu. 

2. Set as My Alarm: Set the selected song as your alarm clock sound. Added music can be chosen in 
the “Alarm sounds” option of the Clock. To select different alarm sounds, go to Home -> Clock and 
Calendar -> Options -> “Alarm sounds.”  

3. Play Mode: Choose a repeat mode to playback multiple music files: Normal, Repeat one, Repeat 
all, Random, Normal in folder, Repeat in folder and Random in folder. 

4. Select source: Select the media source to browse and play music from. Use LEFT and RIGHT to 
select one of the available storage devices and click OK to immediately start browsing folders on 
the selected device. 
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Music Player  

In Music Player mode, the ID3 tag (album name, artist and song title) of the current file is 
displayed as a line of scrolling text at top of the screen. The progress bar in the middle and the digital 
readout at the very bottom of the screen show how much of the song has already been played. Total 
playing time is indicated just below the progress bar. 

 

 

 

 

 

 

 

 

 

 
Figure 21: Music Player 

To start playing music, press  or OK  on a highlighted song in the Music Explorer. The 

Music Player functions are familiar and easy - just like any other player: 

1. Press  to play music and again to pause.  

2. Press  to stop the music.   

3. Adjust the music volume by using the Volume Control Wheel on the left side of PF710 or by 

pressing or  on the remote. 

4. Press  to go back to the previous track and  to play the next song available.  

5. Press the LEFT navigation button to increase playback speed and the OK button to decrease 

playback speed. Press and hold to continue searching for your favorite section of the current song. 

6. Press EXIT or  to go back to Music Explorer mode and select folders or songs to play. Music 

will keep playing unless you press  to stop the music. 

7. Press  on the remote to quickly switch between music play modes. 
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Clock and Calendar 
In the Clock and Calendar mode, your PF710 becomes an attractive desktop calendar and clock that lets 
you set important date reminders and display your favorite photos, too. 

 

 

 

 

 

 

 

 

 

 
Figure 22: Clock and Calendar 

Clock and Calendar 
The Clock and Calendar mode displays a monthly calendar and digital clock on the right-hand side of 

the screen and a selected photo or slideshow on the left. Press LEFT or RIGHT to switch to the previous or 
next month. 

 

 

 

 

 

 

 

 

 

Figure 23: Clock and Calendar options 

Exit : 

Click EXIT or  to return to the Home menu. 

Options:  

Pressing OPTION or  will bring up a list of options available in the Clock and Calendar mode. 

Move LEFT or RIGHT to select the option you want to modify: 

1. Set Alarm: Set the alarm time as follows: 

a. Switch between the hour and minute value of the alarm by pressing LEFT or RIGHT to select 
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the one you want to modify. 

b. Use the UP or DOWN buttons to adjust the minute or hour value that you selected. The time 
format can be either “24H” or “AM/PM,” which can be set in “Options” -> “12H/24H”. 

c. After setting the desired alarm time, press OK or  to save. 

2. Alarm on/off: Enable or disable the alarm. 

3. Alarm sounds: Select the alarm sound you want to be played from a choice of five default alarm 
sounds or your custom “My Alarm” sound (can be any song you want). The “My Alarm” sound can 
be chosen in: Home -> Music -> Options -> “Set as My Alarm.” 

4. 12H/24H: Switch the time display style between 12-Hour (AM/PM) and 24-Hour. This setting 
affects all time displayed in PF710 (alarm, system time, auto on/off).  

5. Important Dates: You can earmark your important dates on the calendar screen. Follow the steps 
below to highlight important dates on the calendar: 

a. Select Important Dates from the Options menu. 

b. Move the cursor on the desired date and press OK to mark that day.  

c. Four mark types are available and are represented by different colors: None, Birthday, Party, 
and Date. Choose one and press OK to confirm. 

6. Picture Display Mode: Change the way pictures are shown next to the calendar: Still Picture 
(single photo) or Slideshow. Slideshow in clock and calendar mode will play all pictures in the 
selected media. The calendar still picture can be chosen in: Home -> Photo View -> Options -> 
“Set as Clock and Calendar Picture.” 

 

 

 

 

 

 

 

 

 

 
Figure 24: Mark important dates 
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Settings 

In the Settings menu, you can inspect your PF710’s current device status – Product name, Firmware 
version, and free space of My Favorites (onboard memory). You can also adjust PF710’s interface 
settings like setting the clock and changing languages.  

 

 

 

 

 

 

 

 

 

 
Figure 25: Settings menu 

The settings menu will appear when you select it from the Home menu or by pressing on the remote. 

Use LEFT and RIGHT to select the setting function that you want to adjust and press OK or  to view 

the submenu for that setting. The following settings are available: 

Language 
Use this function to change the interface language of PF710 (13 languages are currently available). 

The default language is “English.” 

To change the Language: 

1. Select the Language option from the Settings menu. 
2. Use LEFT or RIGHT to highlight the desired language.  

3. Press OK or  to confirm the new language setting. The new setting will be applied 

immediately. 

4. Pressing EXIT or  while in the Language menu will return to the Settings menu.  
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Date/Time Setting 
Use this function to adjust the date/time, set auto power on/off time, and enable or disable auto power 

on/off on the PF710  

 

 

 

 

 

 

 

 

 

 

 

 
Figure 26: Date/Time Settings 

Set Time: 

1. Select Date/Time from the Settings menu, and use the UP or DOWN buttons to select between 
date, time, auto on, auto off or auto on/off timer. 

2. Press OK or  to modify the selected item. 
a. Current Date: Change the PF710’s date. Press LEFT or RIGHT to select year、month or day 

and UP or DOWN to adjust the value. 
b. Current Time: Change the PF710’s internal time. Press LEFT or RIGHT to select hour or 
minute and UP or DOWN to adjust the value. 
c. Auto on at: Set an auto power-on time for your PF710. Press LEFT or RIGHT to select hour 
or minute and UP or DOWN to adjust the value. 
d. Auto off at: Set an auto power-off time for your PF710. Press LEFT or RIGHT to select hour 
or minute and UP or DOWN to adjust the value. 
e. Auto on/off timer: Enable or disable auto power on/off. Press UP or DOWN to adjust the 
value. 

3. After making adjustments, press OK or  to save. 
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Orientation 

You can choose whether you want PF710 to display photos vertically or horizontally with this convenient 
function (note: the orientation setting only applies to Photo View, Thumbnail, and Slideshow modes.) 
There are two orientation modes that you can put your PF710 in: Landscape mode and Portrait mode. If 
you want to view your PF710 photos horizontally, you can set to Landscape mode to change the 
orientation of PF710. If you want to stand or hang your PF710 up vertically, you should choose Portrait 
mode. In the Photo View mode or Slideshow mode, the picture is displayed according to the picture file’s 
orientation information and PF710’s orientation setting. If the PF710 orientation is horizontal, a landscape 
picture fills most of the screen and a portrait picture is shown as a pillarboxed image with black bars on 
either side of the picture. If the PF710 orientation is vertical, a landscape picture is shown as a letterboxed 
image with black bars on top and bottom, and a portrait picture fills most of the screen (If a picture file 
does not have any orientation information, the PF710’s orientation setting will not have any effect.)  Note: 
PF710 preserves the original aspect ratio of all images and does not stretch them to fill the entire screen. 

To set the Orientation function: 

1. Select Orientation from the Settings menu.  
2. Use LEFT or RIGHT to highlight either “Landscape” or “Portrait.”  

3. Press OK or  to confirm the new orientation. 

Display 
Use this function to adjust brightness and contrast of the screen. 

 

 

 

 

 

 

 

 

 

 
Figure 27. Display settings 

To adjust display settings:  

1. Select Display from the Settings menu to open the Display settings, and use the UP and DOWN 
buttons to highlight “brightness”, “contrast” and “fullscreen.” 

2. Press OK or  to modify the selected item. 

a. Brightness: Press LEFT or RIGHT to fine-tune the brightness of the screen. 
b. Contrast: Press LEFT or RIGHT to make adjustments to the screen’s contrast. 
c. Fullscreen: Press UP or DOWN to enable/disable. If disabled, PF710 will preserve the 
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original photo aspect ratio showed in the screen. If enabled, PF710 will enlarge the photo 
to fit the screen, while preserving the original aspect ratio. Depending on its dimensions, 
some parts of the photo may not be displayed in fullscreen mode. Note: fullscreen is only 
applied on horizontal photos displayed in landscape orientation or vertical photos displayed 
in portrait orientation. 

3. After making your adjustments, press the OK button  to save. 

Restore defaults 

This function is available if you want to reset your PF710’s settings. Note: All settings that have been 
changed will return to the factory defaults. 

To restore default settings: 

1. Select Restore defaults from the Settings menu. 
2. Use LEFT or RIGHT to highlight “Yes.” 

3. Press the OK button or  to confirm. 

4. After the process is finished, the Settings menu will be displayed again. 

Firmware upgrade 
Use this function to keep your PF710 up to date. 

To upgrade the firmware: 

1. Insert a storage device such as a USB flash drive or SD/SDHC/MMC/MS/CF memory card that 
contains a newer version of firmware. 

2. Select Firmware upgrade from the Settings menu and press OK to start the firmware detection 
process. PF710 will automatically find the new firmware file. 

3. If PF710 finds that a newer version of firmware is available, a “Yes / No” selection message will 

be shown. Use LEFT or RIGHT to select “Yes” and press OK or  to perform the system 

upgrade. If you do not want to upgrade, press “No” to return to the Settings menu. 
4. The latest firmware version is available on the Transcend website.  
 

 

Note: Do not remove the power cord or any storage devices while the firmware is being 
upgraded. If firmware upgrade fails and the PF710 will not turn on, please contact Transcend 
customer support. 
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Troubleshooting FAQ 
If a problem occurs with your PF710 please first check the information listed below before sending your 
PF710 in for repair. If you are unable to remedy a problem from the following hints, please consult your 
dealer, service center, or local Transcend branch office. We also have FAQ and Support services on our 
websites. For any Hardware issues please consult the PF710 User’s Manual. 

Q: I cannot turn my Transcend PF710 on. 
You may not be holding down the Power button long enough. Please press and hold the Power button for 
at least 3 seconds. If that doesn’t solve the problem, please check to make sure your PF710 is connected 
securely to the DC adapter, and that the adapter is plugged into a wall socket. 

Q: My computer’s operating system cannot detect my PF710. 
Check the following: 
1. Is your PF710 properly connected to the USB port? If not, unplug it and plug it in again. Make sure the 
USB port is connected on both ends, as shown in the User’s Manual. 
2. Is your PF710 connected to the Mac keyboard? If yes, unplug it and plug it into an available USB port 
on your Mac Desktop. 
3. Is the USB port enabled? If not, refer to the user’s manual of your computer (or motherboard) to enable 
it. 

Q: I was using my PF710, now no buttons are responding (hangs/lags/stalls). 

Try unplugging the DC power adapter from your PF710, then reconnecting it to your PF710 again. 

Q: I have connected my PF710 to the computer, but the PF710 does not appear as a 
new drive in my operating system? 
Verify the DC power adapter is connected to your PF710 and that the PF710 power is turned on. If not, 
turn it on and then connect the PF710 to the computer again. Please make sure your operating system 
meets the Transcend PF710 system requirements described in the “Introduction” section. 

Q: My PF710 cannot read photos on my memory card or the built-in memory. 
1. Make sure the memory card that is supported by the PF710. 

2. Ensure that the memory card is correctly inserted all the way into its appropriate slot. 

3. Edited and deformed photos may not display properly on PF710. Some digital cameras save images 
into non-standard formats - please check your camera’s user manual for specifics. 
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Specifications 

 Panel: 7” TFT LCD, 480x234 pixels 

 Speaker: L / R speaker, 0.5w 

 Headphone: 3.5mm, 32 ohm  

 USB Interface: A-Type x1, mini-B x1 

 Storage: 1GB NAND 

 Data Retention: Up to 10 years 

 Navigation: 7 buttons, volume control wheel 

 Remote control: Infrared, NEC protocol 

 Dimension: 219.0 mm × 156.0 mm × 28.0 mm 

 Weight: 430g 

 Power Supply Input: 100 ~ 240 V 1.0A, Output: 5V DC 2.0A 

 Picture Formats: DSC JPEG, motion JPEG, BMP(W:800 x H:600) 

 Music Formats: MP3, WMA (No DRM support), WAV 

 Compression Rates: 32Kbps–320Kbps 

 Certificates: CE, FCC, BSMI 

 Warranty: 
Panel: 1-year, no more than 4 defect pixels 

Device: 2-years 

 
Ordering Information 

Device Description Memory Size Transcend P/N 

PF710  1GB TS1GPF710 

PF710C 1GB TS1GPF710C 
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Transcend Limited Warranty 
“Above and Beyond” is the standard we set ourselves for customer service at Transcend. We 
consistently position ourselves to be significantly above the industry norm, which is all part of our 
commitment to Customer Satisfaction. 
All Transcend information, Inc. (Transcend) products are warranted and tested to be free from defects 
in material and workmanship and to conform to the published specifications. During the warranty period 
should your Transcend PF710 fail under normal use in the recommended environment due to improper 
workmanship or materials, Transcend will repair the product or replace it with a comparable one. This 
warranty is subject to the conditions and limitations set forth herein. 

 

Warranty Period: The Transcend PF710 warranty period is two years from the date of purchase 
(One-year screen warranty: Within one year of the purchase date, Transcend will replace or repair PF710 
screens with four or more defective pixels). Transcend reserves the right to determine whether repair or 
replacement is suitable upon inspection of the product. The decision made by Transcend whether to repair 
or replace the product will be final. Additionally, Transcend reserves the right to provide a functionally 
equivalent refurbished replacement product. 

Limitations: This warranty does not apply to product failure caused by accidents, abuse, mishandling, 
improper installation, alteration, acts of nature, improper usage, or problems with electrical power. In 
addition, opening or tampering with the product casing, or any physical damage, abuse or alteration to the 
product’s surface, including all warranty or quality stickers, product serial or electronic numbers will also 
void the product warranty. Transcend is not responsible for recovering any data lost due to the failure of a 
hard drive device. Transcend’s PF710 must be used with devices that conform to the recommended 
industry standards. Transcend will not be liable for damages resulting from a third party device that causes 
the Transcend PF710 to fail. Transcend shall in no event be liable for any consequential, indirect, or 
incidental damages, lost profits, lost business investments, lost goodwill, or interference with business 
relationships as a result of lost data. Transcend is also not responsible for damage or failure of any third 
party equipment, even if Transcend has been advised of the possibility. This limitation does not apply to 
the extent that it is illegal or unenforceable under applicable law. 

Disclaimer: The foregoing limited warranty is exclusive. There are no other warranties, including any 
implied warranty of merchantability or fitness for a particular purpose. This warranty is not affected in any 
part by Transcend providing technical support or advice. Please read Transcend’s Warranty Policy in full to 
understand your rights. 

Transcend Warranty Policy: http://www.transcendusa.com/Support/Warranty.asp 

Online Registration: To expedite the warranty service, please register your Transcend Product within 30 
days of purchase. 

Register online at http://www.transcendusa.com/registration 

 The specifications mentioned above are subject to change without notice. 

Transcend Information, Inc.

www.transcendusa.com 

*The Transcend logo is a registered trademark of Transcend Information, Inc. 

*All logos and marks are trademarks of their respective companies. 
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Terminology 
desktop........................................................................................................................................................7 
Desktop........................................................................................................................................................2 
This is a single user stationary computer running the Windows®, Mac™, or Linux™ Operating System. 

driver............................................................................................................................................................3 
drivers..........................................................................................................................................................3 
A software program that allows a hardware device to communicate with a computer operating system. 

FAQ ............................................................................................................................................................24 
Frequently Asked Questions. 

Flash ............................................................................................................................................................2 
A form of rewritable computer memory that holds its content independent of its power supply. 

LCD ..........................................................................................................................................................2, 3 
A liquid crystal display (LCD) is a thin, flat display device made up of any number of color or monochrome 
pixels arrayed in front of a light source or reflector. 

Linux ........................................................................................................................................................2, 9 
Linux is one of the most prominent examples of free software and open source operating system. 

Mac OS.....................................................................................................................................................2, 8 
Macintosh is a personal computer made by Apple. Mac OS is the operating system. 

Mini USB......................................................................................................................................................7 
notebook..................................................................................................................................................2, 7 
A portable lightweight computer capable of running off of battery power. 

OSD......................................................................................................................................................10, 11 
On Screen Display icon. 

USB .......................................................................................................................................2, 3, 5, 7, 11,13 
USB A-Type .................................................................................................................................................7 
USB port ......................................................................................................................................................7 
Universal Serial Bus is a hardware interface found on all modern computers for connecting peripherals. 
USB 2.0 is Hi-Speed version of USB interface, capable of data transfer speeds up to 480Mbits per second. 

Windows..................................................................................................................................................2, 7 
Computer Operating System developed by Microsoft. 
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